1

1. ФОРМУЛА МАКСВЕЛЛА-МОРА ДЛЯ ОПРЕДЕЛЕНИЯ ПЕРЕМЕЩЕНИЙ

Наиболее удобной и универсальной для определения перемещений в упругих системах является формула Максвелла-Мора. Для упругих статически определимых систем она имеет следующий вид:

(1)

Формула (1) позволяет определять перемещения в плоской стержневой системе от внешнего воздействия – силового (первых три члена), изменения температуры (четвёртый и пятый члены), смещения опорных связей (шестой член). Но, как правило, перемещения от различных воздействий определяются раздельно. Поэтому рассмотрим далее отдельные виды внешних воздействий.


2

2. МЕТОДЫ ВЫЧИСЛЕНИЯ ИНТЕГРАЛОВ В ФОРМУЛАХ МАКСВЕЛЛА-МОРА

В ФОРМУЛАХ МАКСВЕЛЛА-МОРАРАЛОВоказанной на рис.7:

, а моменты нной в точке К (рис.7б).

е;

й ищется перемещение;

эпюр Для вычисления интегралов в формулах (2), (3) и (5) можно использовать методы: аналитический и численного интегрирования (Верещагина, Симпсона и др.).


3

3. МАТРИЧНАЯ ФОРМА ВЫЧИСЛЕНИЯ ПЕРЕМЕЩЕНИЙ

3.1. Сущность матричной формы вычисления перемещений

Для простоты изложения будем использовать упрощённую формулу определения перемещений с учётом только деформации изгиба.

. (15)

Рассмотрим один из интегралов, входящих в формулу (15), например для участка m. Используя формулу Симпсона, получим

.

Формулу (16) можно записать в матричной форме

, (16)

где [image] – матрица-строка изгибающих моментов на участке m;

– матрица-столбец изгибающих моментов на участке m;

Bm – матрица податливости участка, образованная из коэффициентов формулы Симпсона (16):

,

Полное перемещение в точке К при n участках

(17)

Это равенство можно записать в таком виде:

(18)

где [image] – матрицы изгибающих моментов [image] и Mp

,

,

где q – нулевая матрица.

Таким образом, [image] – матрица-строка, образованная из матриц участков [image] ; [image] – матрица-столбец, образованная из матриц участков [image] ; B – квазидиагональная матрица, образованная из матриц податливости участков.

При записи матриц [image] и [image] нужно принять правило знаков для эпюр изгибающих моментов. Правило знаков устанавливается произвольно. Один из вариантов правила знаков показан на рис.17.

Рисунок 17. Правило знаков на участке.

Согласно рис.17, принято, что знак плюс ставится тогда, когда эпюра М расположена сверху и слева от оси стержня.


1

1.1. Перемещения от силового внешнего воздействия

Перемещения от силового внешнего воздействия определяются по формуле:

(2)

где [image] – аналитические выражения изгибающих моментов, продольных и поперечных сил на i-м участке от заданной внешней нагрузки;

– аналитические выражения изгибающих моментов, продольных и поперечных сил от действия обобщённой единичной силы, приложенной в точке К, перемещение которой ищется, по направлению искомого перемещения;

– жёсткости поперечного сечения стержня соответственно при изгибе, растяжении-сжатии и сдвиге;

m – коэффициент, зависящий от формы поперечного сечения (см. Приложение);

i – номер участка интегрирования;

m1, m2, m3 – количество участков интегрирования;

Si – длина участка интегрирования вдоль оси стержня.

Для вычисления перемещений по формуле (2) необходимо:

1) Определить аналитические выражения внутренних усилий [image] от действия заданной внешней нагрузки и построить при необходимости их эпюры.

2) Определить аналитические выражения внутренних усилий [image] от единичной обобщённой силы и при необходимости их эпюры.

3) Вычислит интегралы в формуле (2) одним из приведённых ниже способов, предварительно установив количество участков интегрирования.

Напомним, что для определения линейного перемещения в качестве единичной обобщённой силы принимается сила Pk = 1, приложенная в точке, перемещение которой ищется по направлению искомого перемещения. Для определения углового перемещения необходимо в соответствующей точке приложить момент Mk = 1.

Таким образом, при определении перемещений рассматриваются два напряжённо-деформированного состояния:

– действительное от заданной нагрузки;

– вспомогательное от единичной обобщённой силы.

Поясним это на примере.

Пусть требуется определить вертикальное перемещение Dс точки С балки, показанной на рис.1 от показанной там же нагрузки. Также требуется определить угол поворота оси балки у опоры А(jА).

Рисунок 1. | Рисунок 2. Действительное состояние

Для определения указанных перемещений вначале определяем [image] от заданной нагрузки, рассматривая действительное состояние балки (рис.2). Имеем

далее для определения Dс рассматриваем первое вспомогательное состояние балки (рис.3а).

Рисунок 3. Вспомогательные состояния.

В этом состоянии имеем два участка.

На первом участке

На втором

Подставляя полученные выражения в формулу (2) и вычисляя интегралы, найдём перемещение Dс.

Для определения угла поворота jА рассматриваем второе вспомогательное состояние (рис.3б).

В точке А прикладываем момент МА = 1 и находим [image] , затем определяем jА.

Необходимо отметить, что в большинстве случаев для определения перемещений от силового воздействия вместо формулы (2) используются упрощённые формулы, которые получаются из (2) путём отбрасывания членов, незначительно влияющих на конечный результат. Эти формулы имеют следующий вид:

– для балок и рам

(3)

– для идеальных шарнирных ферм

(4)

– для комбинированных систем

(5)

В формулах (4) и (5) введены обозначения

– продольные силы в i-ом стержне от внешней нагрузки и силы Pk = 1 соответственно;

Аi, li – площадь поперечного сечения и длина i-го стержня;

m1 – количество стержней в системе.

Напомним, что комбинированной системой называют такую, в которой имеются элементы, работающие преимущественно на изгиб (балка), и элементы, работающие преимущественно на растяжение-сжатие (стержни, соединённые шарнирами) (рис.4).

Рисунок 4. Комбинированная система.

Для определения перемещений в арках, применяемых в строительстве, с достаточной для технических расчётов точностью, можно воспользоваться формулой (2), так как эти арки, как правило, являются арками малой кривизны, для которых r/h > 10 (r - радиус кривизны оси арки, h – толщина). Для арок, не удовлетворяющих этому требованию, используется более полная формула Максвелла-Мора, учитывающая кривизну арки ([1], стр.194).

В заключение отметим, что формула (2) позволяет определить перемещения и статически неопределимых плоских упругих стержневых системах, состоящих из прямолинейных и криволинейных стержней малой кривизны (r/h > 10).


1

1.2. Перемещения от изменения температуры

Перемещения в упругих плоских статически определимых стержневых системах определяются по формуле

(6)

где [image] – изгибающий момент и продольная сила от действия единичной обобщённой силы, приложенной в точке К;

t0 – температура на оси стержня;

Dt – изменение температуры по толщине стержня;

h – толщина стержня в направлении изменения температуры;

a – температурный коэффициент линейного расширения.

Таким образом, первый член формулы представляет перемещение от действия равномерного по толщине нагрева стержня на величину t0, а второй – от неравномерного нагрева на разность температур D t = It 1 – t2 I, где t1 и t2 – температура на поверхности стержня (рис.5).

Рисунок 5. | Рисунок 6.

Необходимо иметь ввиду, что при вычислении перемещения Dkt интегрирование распространяется только на те элементы системы, температурный режим которых изменяется.

Для случая прямолинейных и ломаных стержней постоянного сечения интегралы могут быть подсчитаны как площади единичных эпюр [image] и формула (6) принимает простой вид:

(7)

где [image] – площади единичных эпюр [image] ;

– средняя температура, температура на оси стержня;

h – толщина стержня.

При поперечном сечении элемента, несимметричным относительно оси стержня в формулы (6) и (7) вместо t ср и t0 входит выражение

(8)

где h1 – расстояние от волокна с температурой t2 до оси, проходящей через центр тяжести поперечного сечения.

Правило знаков для членов уравнения (7)

Для первого члена принимается знак плюс (+), если положение растянутых волокон от температуры и изгиба, вызванного единичной обобщённой силой, совпадает. При этом учитывается, что

1) растянутое волокно от изменения температуры расположено со стороны большей температуры;

2) растянутое волокно от обобщённой силы определяется по расположению эпюры [image] , если она построена на растянутом волокне (рис.6).

Знак второго члена получается «автоматически», если площадь эпюры [image] [image] брать со знаком соответствующей эпюры [image] , а за знак температурного члена принимать тот, который получается при расчёте.

Отметим, что величина Dt принимается по абсолютному значению, т.е. Dt = It 1 – t2 I.

Порядок определения перемещения:

3) Прикладывается единичная обобщённая сила (сила или момент, равные единице) в точке, в которой ищется перемещение;

4) Строятся эпюры [image] от единичной обобщённой нагрузки (эпюра [image] строится на растянутом волокне, на эпюре [image] указываются знаки).

5) Определяются площади [image] – по эпюрам [image] .

6) Вычисляются величины Dt, t ср.

7) По формуле (7) определяется перемещение, при этом соблюдаются указанные выше правила знаков.


1

1.3. Перемещение от смещения опорных связей.

Перемещение от смещения опорных связей определяется по формуле

(9)

где [image] – реакция i-ой связи от действия обобщённой силы, приложенной в точке К, в которой ищется перемещение;

D i – заданное перемещение i-ой связи.

Для определения перемещений по формуле (9) нужно рассмотреть два состояния системы:

– действительное, в которой заданы смещения опорных связей (рис.7,а);

– вспомогательное от действия единичной обобщённой силы, приложенной в точке К (рис.7,б).

Рисунок 7. Определение горизонтального перемещения точки К: а – действительное состояние; б – вспомогательное состояние (определение горизонтального перемещения точки К).

Далее необходимо:

1) Для вспомогательного состояния определить реакции тех связей [image] , смещение которых задано в действительном состоянии.

2) Составить сумму работ с обратным знаком реакций [image] вспомогательного состояния на соответствующих смещениях D i действительного состояния. При этом знак произведения [image] принимается плюс (+), если направление реакции [image] и перемещения D i совпадают. При этом нужно помнить, что силы [image] умножаются на соответствующие линейные перемещения, а моменты [image] на углы поворота (рис.8, 9).

в) DKC = –(–RA ·jA) = l | в) DAC = –(–RB ·DB) =DB/l
Рисунок 8. а – действительное состояние; б – вспомогательное состояние; в - результат | Рисунок 9. а – действительное состояние; б – вспомогательное состояние; в - результат

Горизонтальное перемещение точки К для рамы, показанной на рис.7:

.


2

2.1. Аналитический метод

В этом случае находятся аналитические выражения внутренних сил в действительном и вспомогательном состоянии, а затем аналитически, если это возможно, вычисляются интегралы.

Пример.

Требуется определить вертикальное перемещение в точке С для балки, показанной на рис.10а (l = 6 м, q = 2 кН/м).

Рисунок 10.

Для определения вертикального перемещения в точке С прикладываем силу P = 1 и используем формулу (3). В данном случае имеем два участка интегрирования, поэтому

Определяем аналитические выражения усилий

На участке АС:

На участке СВ:

Вычисляем интегралы на участке АС

На участке СВ

Находим искомое перемещение

К недостаткам этого метода следует отнести следующие:

а) значительная трудоёмкость по сравнению с другими методами;

б) не всегда имеется возможность вычислить интегралы в явном виде.

К его достоинству следует отнести точность вычислений.


2

2.2. Метод Верещагина

По методу Верещагина

где [image] – площадь произвольной или ломаной эпюры Mp;

yk – ордината линейной эпюры [image] под центром тяжести эпюры Mp (рис.11).

Рисунок 11.

Следует иметь в виду, что формула (10) применима для участков с прямолинейной осью стержня, на котором EIk = const. При этом выполняется второе условие применимости формулы (10), чтобы эпюра [image] была прямолинейной.

Если обе эпюры прямолинейные, то площадь и ординату можно брать с любой эпюры.

Правило знаков

Если центр тяжести площади эпюры [image] и ордината yk расположены с одной стороны от оси стержня, то принимается знак плюс (+).

При использовании формулы Верещагина приходиться вычислять площади различных геометрических фигур и определять положение их центра тяжести. Для этого сложные геометрические фигуры разбивают на простые. Всё это усложняет применение метода Верещагина в сравнении, например, с методом Симпсона. Поэтому представляется возможным рекомендовать применение формулы Верещагина в том случае, когда площади геометрических фигур, положение их центра тяжести определяются просто, а также просто вычисляются ординаты других фигур, под центром тяжести первых (рис.12).

Рисунок 12.


2

2.3. Метод Симпсона

Для более сложных, чем на рис.12, эпюр для вычисления интегралов в формуле Максвелла-Мора целесообразно применять формулу Симпсона

(11)

где f(a), f(c), f(b) – значения подынтегральной функции f(x) на концах (f(a), f(b)) и посередине f(с) интервала интегрирования;

a, b, c – значения x в крайних (a, b) и средней (c) точках интервала интегрирования (рис.13).

Рисунок 13.

При вычислении по формуле Симпсона (11) обе эпюры могут быть криволинейными, жёсткости стержня переменными, ось стержня криволинейной. Однако, при криволинейной оси стержня от интеграла по координате вдоль оси стержня

нужно перейти к интегралу по координате вдоль прямолинейной оси, например, x

,

где a – угол наклона касательной к оси стержня в точке с координатой x и оси x (рис.14).

Рисунок 14.

Однако, точное значение интеграла будет иметь место лишь тогда, когда стержня прямолинейная, жёсткость на участке постоянная, обе эпюры прямолинейные или одна из них прямолинейная, а вторая – квадратичная парабола.

В других случаях для увеличения точности результатов интегрирования нужно уменьшить длину участка интегрирования lk.

Применительно к эпюрам Mp и [image] формула Симпсона имеет следующий вид:

при переменной жёсткости на участке

(12)

при постоянной жёсткости на участке

(13)

где a = [image] , c = [image] , b = [image] – значение моментов Mp в начале (точка А), посредине (точка С) и на конце (точка B) участка интегрирования;

– тоже для моментов [image] ;

lk – длина участка интегрирования вдоль оси с;

EIA, EIC, EIB – значения изгибной жёсткости в начале, посредине и на конце участка интегрирования (рис.15).

Рисунок 15.

Если обе эпюры прямолинейные, ось стержня на участке – прямая линия, а жёсткость EIk = const, то формула (13) с помощью подстановки

преобразуется в формулу

(14)

которую часто называют формулой трапеции (рис.16).

Рисунок 16.

Правило знаков

Если перемножаемые ординаты эпюр Mp и [image] лежат с одной стороны, то принимаем знак плюс (+), в противном случае – знак минус (–).

Согласно этому правилу для эпюр, показанных на рис.16,

.

Для эпюр, показанных нарис.15,

.


3

3.2. Алгоритм определения перемещений в матричной форме

  1. Строим эпюру изгибающих моментов Mp от заданной нагрузки.
  2. Строим эпюру изгибающих моментов [image] от единичной силы (Pk = 1 или Mk = 1), приложенной в точке, в которой имеется перемещение.
  3. Определяется число участков интегрирования. При этом учитываются одновременно виды эпюр Mp и [image] , строение рамы (балки), жёсткость стержней.
  4. На эпюрах Mp и [image] указываются знаки в соответствии с принятым правилом знаков.
  5. На каждом участке задаются три или два значения изгибающих моментов.
  6. Формируются матрицы изгибающих моментов [image] и [image] по участкам и затем матрицы моментов [image] и [image] для всей рамы в целом. Очевидно, что сразу можно формировать матрицы [image] и [image] .
  7. Формируются матрицы податливости участков Bk, а затем матрица податливости рамы (балки) B.
  8. Производится перемножение матриц C = LM·B, D = C·LMp.
  9. Искомое перемещение D = D.

Пример. Определить горизонтальное перемещение точки С для рамы, показанной на рис.18.

Рисунок 18.

В данном случае на эпюре Mp имеем три участка, а на эпюре [image] – один. Следовательно, число участков n = 3.

Матрицы моментов для участков 1, 2, 3 имеют вид:

.

Матрицы податливости для участков:

.

По матрицам участков формируем матрицы [image] , [image] , В.

,

.

Следует обратить внимание, что в матрице В выносится общий множитель [image] , а элементы матриц участков Bk умножаются соответственно на коэффициенты [image] , где l1 и I1 – длина и жёсткость участка, принятого за основной.

Так, в данном примере матрицы B1 и B2 умножаются на коэффициенты g1 = g2 = 1, а матрица В3 – на коэффициент g3 = 0,5.

Для определения перемещения в точке С перемножаем матрицы:

а)

б) [image] ,

таким образом, искомое горизонтальное перемещение точки С

.


3

3.3. Упрощение матриц моментов и податливости

а) Для рам и балок.

Если на участке обе эпюры прямолинейные, то, как отмечалось выше, может быть использована формула Симпсона в форме формулы трапеций (14). В этом случае в матрицах моментов достаточно указывать лишь два значения в начале и в конце участка

а матрица податливости принимает вид

.

б) Для ферм.

Перемещения в ферме определяются по формуле (4). В матричной форме она запишется таким образом

где

– усилия в стержнях фермы от единичной силы P = 1, приложенной в узле, перемещение которого ищется;

Nkp – усилия в стержнях фермы от заданной нагрузки;

l0, F0 – длина и площадь, принятые за основные;

Bk – приведённые податливости стержней, определяют по формуле


От автора

Сразу надо сказать, что я не являюсь ИСТИННЫМ автором данной работы.

А решил сделать электронную версию я вот почему. Как-то, ещё учась в вузе, на хозработах мы вносили на свалку разные ненужные бумаги (старые курсовые, тетради и т.п.). Там же попадались и методические указания, в основном, они были уже совсем устаревшими, но среди них мне попались и методические указания по определению перемещений. Они были напечатаны на жёлтой (даже уже коричневой от времени) бумаге, да качество печати оставляло желать лучшего. Но я, всё же решил оставить их себе и не ошибся. Очень часто мне пришлось пользоваться ими.

С тех пор прошло уже несколько лет, и дома я случайно наткнулся на них. Мне пришла в голову мысль, что хорошо бы перепечатать их, чтобы новое поколение студентов тоже могло использовать это.

А идея электронной версии пришла потому что – это самый лёгкий способ распространения (особенно, при помощи Internet’а).

СОСТАВИТЕЛЯМИ первой версии этого издания являются (насколько мне удалось разобрать фамилии):

Коперник Г.Р.

Козлов В.В.

Автор электронной версии (восстановление текста и графики, редактирование, программирование):

AM-Bridge (www.am-bridge.narod.ru)

Настоящее издание разрешено к СВОБОДНОМУ РАСПРОСТРАНЕНИЮ без каких-либо изменений.


ВВЕДЕНИЕ

Настоящие методические указания предназначены для студентов, самостоятельно изучающих тему «Определение перемещений для плоских упругих систем» и выполняющих расчётно-проектировочные работы, содержащие вопросы определения перемещений. В них особое внимание уделяется матричной форме определения перемещений с применением ЭВМ.

Сооружения должны быть не только прочными, но и достаточно жёсткими. Это означает, что перемещение различных точек сооружения, возникающие при его деформации, должны быть достаточно малыми. Например, наибольший прогиб главной балки междуэтажного перекрытия не должен превышать 1/400 длины её пролёта.

Таким образом, определение перемещений сооружения необходимо для оценки жёсткости сооружения и расчёта его по второму предельному состоянию. Кроме этого, определение перемещений необходимо:

1) для сопоставления теоретических и опытных перемещений при контроле сооружений после их постройки и после длительной эксплуатации;

2) для расчёта статически неопределимых систем, при динамических расчётах.


ЛИТЕРАТУРА

  1. Киселёв В.А. Строительная механика. Общий курс: учебник для вузов.– М.: Стройиздат, 1986.-520 с.
  2. Дарков А.В., Шапошников Н.Н. Строительная механика: учебник для строительных специальностей вузов.– М.: Высшая школа, 1988.-887 с.
  3. Руководство к практическим занятиям по курсу строительной механики: Учебное пособие для студентов вузов./ Г.К. Клейн, Н.Н. Леонтьев и др.; Под ред. Г.К. Клейна.– М.: Высшая школа, 1980.-384 с.
  4. Сидоров В.Н. Лекции по сопротивлению материалов и теории упругости.– М.: Редакционно-издательский центр Генерального штаба ВС РФ, 2002.-352 с.


ОПРЕДЕЛЕНИЕ ПЕРЕМЕЩЕНИЙ В СТАТИЧЕСКИ ОПРЕДЕЛИМЫХ СИСТЕМАХ

Методические указания к выполнению расчётно-проектировочной работы по разделу «Расчёт статически определимых систем» курса «Строительная механика»


Меню

Начало

От автора

ВВЕДЕНИЕ

1. ФОРМУЛА МАКСВЕЛЛА-МОРА ДЛЯ ОПРЕДЕЛЕНИЯ ПЕРЕМЕЩЕНИЙ

1.1. Перемещения от силового внешнего воздействия

1.2. Перемещения от изменения температуры

1.3. Перемещение от смещения опорных связей

2. МЕТОДЫ ВЫЧИСЛЕНИЯ ИНТЕГРАЛОВ В ФОРМУЛАХ МАКСВЕЛЛА-МОРА

2.1. Аналитический метод

2.2. Метод Верещагина

2.3. Метод Симпсона

3. МАТРИЧНАЯ ФОРМА ВЫЧИСЛЕНИЯ ПЕРЕМЕЩЕНИЙ

3.1. Сущность матричной формы вычисления перемещений

3.2. Алгоритм определения перемещений в матричной форме

3.3. Упрощение матриц моментов и податливости

ПРИЛОЖЕНИЕ

ЛИТЕРАТУРА


ПРИЛОЖЕНИЕ

Коэффициент m определяется по формуле:

.

Значения коэффициента m для некоторых поперечных сечений:

– для прямоугольника m = 1,2;

– для круга [image] ;

– для прокатных двутавров [image] , где F – полная площадь; Fст – площадь вертикальной стенки.